Security Lab

Переполнение буфера в nfs-utils

Дата публикации:18.07.2003
Дата изменения:21.10.2008
Всего просмотров:1178
Опасность:
Средняя
Наличие исправления: Да
Количество уязвимостей:1
CVE ID: Нет данных
Вектор эксплуатации: Локальная сеть
Воздействие: Отказ в обслуживании
Компрометация системы
CWE ID: Нет данных
Наличие эксплоита: Нет данных
Уязвимые продукты: nfs-utils 0.x
nfs-utils 1.x
Уязвимые версии: nfs-utils 1.0.3 и более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за ошибки завышения на единицу в функции "xlog()" во время добавления отсутствующего символы новой строки к сохраняемой строке. Удаленный пользователь может с помощью специально сформированного RPC запроса к службе rpc.mountd service вызвать переполнение буфера и выполнить произвольный код на целевой системе.

URL производителя: sourceforge.net/projects/nfs/

Решение: Установите последнюю версию 1.0.4 с сайта производителя.

Ссылки: Linux nfs-utils xlog() off-by-one bug