В последней версии библиотеки OpenSSL обнаружена опасная уязвимость

В последней версии библиотеки OpenSSL обнаружена опасная уязвимость

Уязвимость позволяет удаленному атакующему повредить содержимое памяти процесса.

image

Уязвимость обнаружена в последней версии OpenSSL 3.0.4 , вышедшей 21 июня 2022 года и затрагивает системы x86_64 с поддержкой инструкций AVX-512 .

Согласно информации из блога ИБ-специалиста Гвидо Вранкена , уязвимость может быть использована удаленным злоумышленником для повреждения содержимого памяти процесса. Успешная эксплуатация уязвимости может позволить хакеру прочесть и перезаписать до 8129 байт данных за пределами выделенного буфера. Пока неизвестно, возможно ли использовать уязвимость для выполнения произвольного кода атакующего.

BoringSSL, LibreSSL и ветка OpenSSL 1.1.1 не подвержены уязвимости. Исправление пока доступно только в виде патча и станет доступно всем пользователям в следующем обновлении.


Мир на грани катастрофы и только те, кто подпишется на наш телеграм канал, смогут выжить в Киберапокалипсисе!