Fortinet устранила уязвимости, обнаруженные Positive Technologies

Fortinet устранила уязвимости, обнаруженные Positive Technologies

В числе угроз — выполнение произвольного кода и перехват учетной записи администратора

Компания Fortinet закрыла четыре уязвимости в FortiWeb, выявленные экспертом Positive Technologies Андреем Медовым. FortiWeb — семейство межсетевых экранов для защиты веб-приложений.

Первая уязвимость ( CVE-2020-29015 , оценка 6,4 по шкале CVSS v3.1) позволяет осуществить слепое внедрение SQL-кода (blind SQL injection) через пользовательский интерфейс FortiWeb. Неавторизованный злоумышленник может удаленно выполнять произвольные SQL-запросы, отправляя запрос с заголовком авторизации, содержащим вредоносный SQL-оператор. Для устранения проблемы нужно обновить FortiWeb 6.3.x и 6.2.x до версий 6.3.8 и 6.2.4 соответственно.

Две другие уязвимости связаны с переполнением буфера в стеке. Ошибка CVE-2020-29016 (оценка 6,4) может позволить неавторизованному удаленному злоумышленнику перезаписать содержимое стека и выполнить произвольный код, отправив запрос со специально сформированным GET-параметром certname. Для исправления нужно обновить FortiWeb 6.3.x и 6.2.x до версий 6.3.6 и 6.2.4 соответственно. Уязвимость CVE-2020-29019 (оценка также 6,4) может использоваться для DoS-атаки на демон httpd с помощью запроса со специально сформированным cookie-параметром. Необходимо обновление до 6.3.8 и 6.2.4.

Четвертая уязвимость ( CVE-2020-29018 , оценка 5,3) — уязвимость форматной строки (format string) — позволяет прочитать содержимое памяти, получить конфиденциальные данные, выполнить несанкционированный код или команды с помощью параметра redir. Атака реализуется удаленно. Пользователям следует обновить FortiWeb 6.3.x до версии 6.3.6.

Исправления были опубликованы Fortinet PSIRT 4 января 2021 года. Разработчик настоятельно рекомендовал своим клиентам установить обновления как можно скорее.

«Наиболее опасными среди этих четырех уязвимостей являются SQL-инъекция (CVE-2020-29015) и buffer overflow (CVE-2020-29016), — рассказывает Андрей Медов. — Эксплуатация обеих ошибок не требует авторизации. Первая позволяет из-за избыточных привилегий пользователя СУБД получить хеш учетной записи администратора системы (что дает доступ к API, причем без расшифровки хеш-значения), вторая — выполнить произвольный код. Уязвимость format string (CVE-2020-29018) тоже потенциально ведет к выполнению кода, но для ее эксплуатации требуется авторизация».


Анонсы лучших вебинаров, курсов и других ИБ событий, тщательно отобранных экспертами на нашем телеграмм канале. Большинство мероприятий бесплатные!