Уязвимость в PolicyKit позволяет выполнить любую команду на системах Linux

image

Теги: PolicyKit, Linux, уязвимость, обход аутентификации

Проблема существует в связи с некорректной обработкой PolicyKit идентификаторов со значением, превышающим INT_MAX.

В программной платформе для управления административными политиками и привилегиями PolicyKit обнаружена уязвимость обхода аутентификации, позволяющая пользователю с низкими привилегиями успешно выполнить любую команду systemctl на Linux-системах со значением UID, превышающим 2147483647.

Уязвимость, получившая идентификатор CVE-2018-19788, затрагивает версию PolicyKit (polkit) 0.115, предустановленную в большинстве популярных дистрибутивов Linux, включая Red Hat , Debian , Ubuntu и CentOS. Проблема существует в связи с некорректной обработкой PolicyKit идентификаторов со значением, превышающим INT_MAX.

Исследователь в области безопасности Рич Мирч (Rich Mirch) опубликовал на GitHub PoC-код, демонстрирующий процесс эксплуатации уязвимости. Проблема устранена в версии 0.105-18+deb9u1. Разработчики Red Hat готовят соответствующий патч, а пока рекомендуют не использовать идентификаторы со значением больше 2147483646.

Telegram Подписывайтесь на канал "SecurityLab" в Telegram, чтобы первыми узнавать о новостях и эксклюзивных материалах по информационной безопасности.