Разработчики Android-приложений смогут заставлять пользователей устанавливать патчи

image

Теги: Google, Android, API, приложение, обновление

Новый API от Google позволит разработчикам заставлять или подталкивать пользователей к установке обновлений.

Google предоставила разработчикам Android-приложений новый API, с помощью которого они смогут принудительно заставлять пользователей обновляться до последних версий ПО.

На этой неделе в ходе саммита разработчиков Android Dev Summit компания объявила о выходе In-app Updates API для создания немедленного или гибкого процесса обновления приложений, либо заставляющего, либо подталкивающего пользователей на установку обновлений.

Разработчики смогут сами выбирать наиболее подходящий вариант в зависимости от того, насколько экстренным является обновление. К примеру, для критических патчей разработчики смогут использовать процесс немедленного обновления. Когда пользователь зайдет в приложение, на весь экран откроется уведомление о необходимости установить обновление, и пользователь не сможет работать с приложением до тех пор, пока не установит патчи.

Гибкий процесс обновления позволит продолжить пользование приложением, пока загружаются обновления.

С выходом нового API у разработчиков появится возможноть исправлять серьезные уязвимости и ошибки в приложении после его релиза. Кроме того, с его помощью они смогут подталкивать пользователей к установке последних версий приложений с новыми функциями, которые разработчики хотят сделать доступными для всех.

Telegram Подписывайтесь на канал "SecurityLab" в Telegram, чтобы первыми узнавать о новостях и эксклюзивных материалах по информационной безопасности.