Уязвимости в SCADA-системе LCDS ставят под угрозу безопасность предприятий

image

Теги: LCDS, SCADA, АСУ ТП, уязвимость

Проблемы позволяют выполнить произвольный код, вызвать сбой в работе системы или записать контент.

Пакет программного обеспечения LAquis SCADA производства LCDS (Leão Consultoria e Desenvolvimento de Sistemas LTDA ME) содержит ряд опасных уязвимостей, позволяющих выполнить произвольный код, вызвать сбой в работе системы или записать контент на систему. Проблемам подвержены версии LAquis SCADA Smart Security Manager 4.1.0.3870 и более ранние.

В продукте выявлены множественные уязвимости, связанные с переполнением буфера и возможностью записи/чтения за пределами выделенной области памяти. Проблемы объединены под общими идентификаторами CVE-2018-17901, CVE-2018-17897, CVE-2018-17895 и CVE-2018-17911. Остальные баги (CVE-2018-17893 и CVE-2018-17899) относятся к типам «разыменование недоверенного указателя» (untrusted pointer dereference) и «обход каталога» (path traversal). Степень опасности проблем варьируется от 5,3 до 7,8 баллов по классификации CVSS v3. Все вышеуказанные уязвимости предоставляют возможность удаленного выполнения кода.

Проблемы устранены в версии LAquis SCADA Smart Security Manager 4.1.0.4114. Обновление доступно на сайте производителя. Всем пользователям рекомендуется обновить программное обеспечение как можно скорее.

LAquis SCADA - инструмент для сбора данных, контроля процессов промышленной автоматизации, хранения, формирования отчетов для развития управления качеством.

Telegram Подписывайтесь на канал "SecurityLab" в Telegram, чтобы первыми узнавать о новостях и эксклюзивных материалах по информационной безопасности.