В популярных NMS-системах обнаружены опасные уязвимости

image

Теги: уязвимость, XSS-атака, SQL-инъекции

Компания Rapid7 провела исследование безопасности различных NMS-решений.

Компания Rapid7 провела аудит безопасности самых популярных систем для управления сетью network management system, NMS) от крупных производителей. В ходе исследования были обнаружены множественные уязвимости, позволяющие осуществить XSS-нападение и выполнить произвольные SQL-команды в базе данных приложения.

По данным исследователей, web-интерфейс в системе Spiceworks Desktop подвержен хранимой XSS-уязвимости (CVE-2015-6021). Ошибка существует в версиях 7.3.00065, 7.3.00076 и 7.4.00075. Злоумышленник может внедрить XSS эксплоит в ответ SNMP-агента, полученный во время сканирования сети приложением. Эксплоит будет выполнен автоматически при просмотре определенных страниц web-интерфейса администратором приложения. Об уязвимости разработчику стало известно 1 сентября нынешнего года, а исправленная версия 7.5 вышла во вторник, 1 декабря.

Продукт Ipswitch WhatsUp Gold также содержит несколько уязвимостей. Исследователи обнаружили в продукте две ошибки, позволяющие осуществить XSS-атаку (CVE-2015-6004) и SQL-инъекцию (CVE-2015-6005).

Хранимая XSS-уязвимость может быть проэксплуатирована через SNMP во время процесса обнаружения сетевых устройств. Вредоносный код будет выполнен при просмотре страниц в web-интерфейсе. Вторая ошибка позволяет авторизованному пользователю выполнить произвольные SQL-команды и извлечь информацию из базы данных. В среду, 16 декабря, производитель выпустил исправленную версию WhatsUp Gold 16.4.1.

В Opsview было обнаружено две XSS-уязвимости. Подробная информация об ошибках отсутствует. Недостатки затрагивают Opsview 4.6.3 и более ранние версии. Уязвимости были исправлены 16 ноября нынешнего года.

В продуктах Castle Rock Computing SNMPc Enterprise и SNMPc OnLine были также обнаружены две уязвимости. Одна из ошибок позволяет осуществить XSS-атаку (CVE-2015-6027) в ходе обнаружения новых устройств в сети. С помощью второй уязвимости злоумышленник может выполнить произвольные SQL-команды (CVE-2015-6028) и извлечь информацию из базы данных приложения. По словам представителей Castle Rock Computing, ошибки были исправлены в четверг, 17 декабря.

Telegram Подписывайтесь на канал "SecurityLab" в Telegram, чтобы первыми узнавать о новостях и эксклюзивных материалах по информационной безопасности.