Выполнение произвольного кода в WordPress Zingiri Web Shop Plugin

Дата публикации:
14.11.2011
Дата изменения:
15.11.2011
Всего просмотров:
4397
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:C/I:C/A:C/E:P/RL:O/RC:C) = Base:10/Temporal:7.8
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
PoC код
Уязвимые продукты:
WordPress Zingiri Web Shop Plugin 2.x
Уязвимые версии: WordPress Zingiri Web Shop Plugin 2.2.3, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за недостаточной проверки данных в сценарии wp-content/plugins/zingiri-web-shop/fws/addons/tinymce/jscripts/tiny_mce/plugins/ajaxfilemanager/ajax_file_cut.php в параметре selectedDoc[]. Удаленный пользователь может внедрить произвольный PHP код в определенный PHP файл. http://wordpress.org/extend/plugins/zingiri-web-shop/

Решение: Обновите продукт до версии 2.2.4.

Ссылки: Wordpress Zingiri Web Shop Plugin <= 2.2.3 Remote Code Execution Exploit
http://wiki.zingiri.com/index.php?title=Changelog
Журнал изменений: 15.11.2011
Добавлен PoC код, изменена метрика CVSS.

или введите имя

CAPTCHA