PHP-инклюдинг в cpCommerce

Дата публикации:
01.06.2009
Дата изменения:
01.06.2009
Всего просмотров:
2569
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
cpCommerce 1.x
Уязвимые версии: cpCommerce 1.2.9, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "GLOBALS[prefix]" в сценарии _functions.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP.

URL производителя: cpcommerce.cpradio.org

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: cpCommerce 1.2.x GLOBALS[prefix] Arbitrary File Inclusion Exploit

или введите имя

CAPTCHA