Ошибка завышения на единицу в wzdftpd

Дата публикации:
08.10.2007
Дата изменения:
28.01.2008
Всего просмотров:
1185
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
wzdftpd 0.x
Уязвимые версии: wzdftpd 0.8.2, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании или выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки завышения на единицу в функции "do_login_loop()" в файле libwzd-core/wzd_login.c. Удаленный пользователь может послать серверу слишком длинную строку (более 4095 байт), вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.wzdftpd.net

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: wzdftpd <= 0.8.0 (USER) Remote Denial of Service Exploit

или введите имя

CAPTCHA