Отказ в обслуживании в Asterisk

Дата публикации:
31.07.2007
Дата изменения:
02.08.2007
Всего просмотров:
1141
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная сеть
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Asterisk 1.x
Asterisk Appliance Developer Kit 0.x
Уязвимые версии:
Asterisk Open Source 1.2.x версии 1.2.20, 1.2.21, 1.2.21.1, и 1.2.22
Asterisk Open Source 1.4.x версии 1.4.5, 1.4.7, 1.4.7.1 и 1.4.8
AsteriskNOW pre-release версии beta6
Asterisk Appliance Developer Kit 0.5.0 s800i версии 1.0.0-beta5 до 1.0.2

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании приложения.

Уязвимость существует из-за некорректной обработки "NEW" пакетов в IAX2 Channel Driver. Удаленный пользователь может послать большое количество "NEW" пакетов серверу, что заставит приложение выделить ресурсы, которые никогда не будут освобождены. Удаленный пользователь может вызвать отказ в обслуживании приложения. Для успешной эксплуатации уязвимости требуется, чтобы IAX2 Channel Driver был сконфигурирован на обработку неаворизованных звонков.

URL производителя: www.asterisk.org

Решение: Установите последнюю версию с сайта производителя.

Asterisk Open Source 1.2.x:
Установите последнюю версию 1.2.23.
ftp://ftp.digium.com/pub/telephony/asterisk

Asterisk Open Source 1.4.x:
Установите последнюю версию 1.4.9.
ftp://ftp.digium.com/pub/telephony/asterisk

AsteriskNOW pre-release:
Update to version beta7.
http://www.asterisknow.org

Asterisk Appliance Developer Kit:
Установите последнюю версию 0.6.0.
ftp://ftp.digium.com/pub/telephony/aadk

s800i:
Установите последнюю версию 1.0.3.

Ссылки: Asterisk < 1.2.22, 1.4.8 IAX2 channel driver Remote Crash Exploit

или введите имя

CAPTCHA