PHP-инклюдинг в Skrypty PPA Gallery

Дата публикации:
03.10.2006
Дата изменения:
17.10.2006
Всего просмотров:
1914
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Skrypty PPA Gallery 0.x
Уязвимые версии: Skrypty PPA Gallery 0.5.6, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "config[ppa_root_path]" в сценарии inc/functions.inc.php. Удаленный пользователь может выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP.

URL производителя: skrypty.webpc.pl/ocena.php?id=602

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: PPA Gallery <= 1.0 (functions.inc.php) Remote File Include Exploit

или введите имя

CAPTCHA