Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Установка perl у меня самые первый ошибки
 
установил ActivePerl-5.6.1.638-MSWin32-x86.msi
в конфиге апаче вроде все так зделал,
давлю"http://127.0.0.1/cgi-bin/test.cgi"
так он долго грузит страницу и не откывает не чего, потскажите а то совсем все забыл все заного начинаю :(
 
А можно взглянуть, что Вы прописали в конфиге?
 
ScriptAlias /cgi-bin/ "D:/cgi-bin/"

#
# "D:/usr/Apache/Apache2/cgi-bin" should be changed to whatever your ScriptAliased
# CGI directory exists, if you have that configured.
#
<Directory "D:/cgi-bin">
      AllowOverride None
      Options None
</Directory>


AddHandler cgi-script .bat .exe .cgi .pl
ScriptInterpreterSource registry
 
How do I use ActivePerl under Apache?

If you want to put all of your CGI scripts into one directory, add the following line to your srm.conf file (You can choose any directory youd like, but make sure it exists):

    ScriptAlias /cgi-bin/ "C:/Program Files/Apache Group/Apache/cgi-bin/"

After you have made this change, stop and restart the Apache service.

Apache provides an emulation of the UNIX shebang (#!/path/to/perl) syntax, so the next step is easy. You can put you Perl scripts into your cgi-bin directory, as long as you have a path to a valid interpreter at the top. For example:

    #!C:\PERL\5.00464\bin\MSWin32-x86\pe rl.exe
     
    use CGI qw(:standard) ;
    print header();
    print "Hello, world";

If you want to enable CGI scripts based on an extension, such as .pl, you need to add the following line to srm.conf:

    AddHandler cgi-script .pl

By default, CGI scripts are not allowed in your DocumentRoot directory, but they are allowed in other document directories. Document directories are created with the Alias command in srm.conf:

    Alias /ResourceKit/ "E:/utilsamp/"

You can then include files that end in .pl within a document directory. You will still need to include the #! line with the full path to the perl.exe interpreter, as shown earlier.

If you want to allow CGI scripts in the DocumentRoot directory, add the ExecCGI option to the Options directive between the <Directory> and </Directory> entry for your DocumentRoot in access.conf (these appear directly after the comment titled:

    # This should be changed to whatever you set DocumentRoot to.

After you have updated it, your Options directive may look something like:

    Options Indexes FollowSymLinks ExecCGI
Страницы: 1
Читают тему (гостей: 1)