Отказ в обслуживании в strongSwan

Дата публикации:
26.01.2015
Дата изменения:
26.01.2015
Всего просмотров:
721
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:A/AC:L/Au:N/C:N/I:N/A:P/E:U/RL:O/RC:C) = Base:3.3/Temporal:2.4
CVE ID:
CVE-2014-9221
Вектор эксплуатации:
Локальная сеть
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
strongSwan 4.x
strongSwan 5.x
Уязвимые версии:
strongSwan 4.5.0
strongSwan 5.2.1

Описание:

Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании.

Уязвимость существует из-за ошибки при обработке сообщений IKE_SA_INIT, содержащих полезную нагрузку IKEv2 Key Exchange (KE) с DH group MODP_CUSTOM(1025). Удаленный пользователь может с помощью специально сформированного сообщения IKE_SA_INIT аварийно завершить работу системы.


URL производителя: http://strongswan.org/

Решение: Установите последнюю версию 5.2.2 с сайта производителя.

Ссылки: http://strongswan.org/blog/2015/01/05/strongswan-5.2.2-released.html
http://strongswan.org/blog/2015/01/05/strongswan-denial-of-service-vulnerability-(cve-2014-9221).html
http://download.strongswan.org/patches/17_modp_custom_patch/