SQL-инъекция в Zend Framework

Дата публикации:
17.06.2014
Дата изменения:
17.06.2014
Всего просмотров:
581
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:/I:/A:/E:U/RL:O/RC:C) = Base:0/Temporal:0
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Zend Framework 1.x
Уязвимые версии: Zend Framework 1.x, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

Уязвимость существует из-за недостаточной обработки входных данных в функции "Zend_Db_Select::order()". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

URL производителя: http://www.zend.com/

Решение: Установите последнюю версию 1.12.7 с сайта производителя.

Ссылки: http://framework.zend.com/security/advisory/ZF2014-04

или введите имя

CAPTCHA