Обход ограничений безопасности в Liferay Faces Bridge

Дата публикации:
06.06.2014
Дата изменения:
06.06.2014
Всего просмотров:
860
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:P/I:P/A:P/E:U/RL:O/RC:C) = Base:7.5/Temporal:5.5
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Liferay Faces Bridge 3.x
Liferay Faces Bridge 4.x
Уязвимые версии: Liferay Faces Bridge 3.0.0-legacy-ga1, 3.0.1-legacy-ga2, 3.0.2-legacy-ga3, 3.0.3-legacy-ga4, 3.0.4-legacy-ga5, 3.0.0-ga1, 3.0.1-ga2, 3.0.2-ga3, 3.0.3-ga4, 3.0.4-ga5, 3.1.0-ga1, 3.1.1-ga2, 3.1.2-ga3, 3.1.3-ga4, 3.1.4-ga5, 3.2.4-ga5, 4.1.0-m1 и 4.2.0-m1, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю обойти ограничения безопасности.

Уязвимость существует из-за недостаточной обработки входных данных в параметрах "_jsfBridgeViewId", "_facesViewIdRender" и "_facesViewIdResource" в сценарии bridge-impl/src/main/java/com/liferay/faces/bridge/context/BridgeContextImpl.java. Подробности уязвимости не раскрываются.

URL производителя: http://www.liferay.com/

Решение: Установите последнюю версию 3.0.5-legacy-ga6, 3.0.5-ga6, 3.1.5-ga6, 3.2.5-ga6, 4.1.0-m2 или 4.2.0-m2 с сайта производителя.

Ссылки: http://www.liferay.com/community/security-team/known-vulnerabilities/-/asset_publisher/T8Ei/content/cst-sa-faces-1917-security-vulnerability-with-_jsfbridgeviewid-_facesviewidrender-and-_facesviewidresource-url-parameter-values
https://issues.liferay.com/browse/FACES-1917

или введите имя

CAPTCHA