Межсайтовый скриптинг в MediaWiki

Дата публикации:
05.06.2014
Дата изменения:
05.06.2014
Всего просмотров:
608
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
CVE-2014-3966
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
MediaWiki 1.x
Уязвимые версии: MediaWiki 1.x, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "Username" в странице "Special:PasswordReset". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

Для успешной эксплуатации уязвимости wgRawHtml должен быть включен.

URL производителя: http://www.mediawiki.org/wiki/MediaWiki

Решение: Установите последнюю версию 1.19.16, 1.21.10 или 1.22.7 с сайта производителя.

Ссылки: http://lists.wikimedia.org/pipermail/mediawiki-announce/2014-May/000151.html

или введите имя

CAPTCHA