Множественные уязвимости в GnuTLS libtasn1 Tiny ASN.1 library

Дата публикации:
03.06.2014
Дата изменения:
03.06.2014
Всего просмотров:
665
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
3
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:N/A:P/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
(AV:N/AC:L/Au:N/C:N/I:N/A:P/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
CVE ID:
CVE-2014-3467
CVE-2014-3468
CVE-2014-3469
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
GnuTLS libtasn1 Tiny ASN.1 library 3.x
Уязвимые версии: GnuTLS libtasn1 Tiny ASN.1 library 3.x, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю обойти ограничения безопасности и вызвать отказ в обслуживании приложения использующего библиотеки.

1. Уязвимость существует из-за некоторых ошибок проверки границ данных в функциях "asn1_get_tag_der()", "_asn1_get_indefinite_length_string()", "asn1_der_decoding()", "asn1_der_decoding_startEnd()", "_asn1_extract_tag_der()", "_asn1_get_octet_string()", "_asn1_extract_der_octet()", "_asn1_get_time_der()" и "_asn1_get_objectid_der()" в файле lib/decoding.c. Удаленный пользователь может вызвать вне границ доступ на чтение к памяти.

2. Уязвимость существует из-за ошибки в функции "asn1_get_bit_der()" в файле lib/decoding.c. Подробности уязвимости не раскрываются.

2. Уязвимость существует из-за ошибки разыменования нулевого указателя в функциях "asn1_write_value()", "asn1_read_value_type()" и "_asn1_convert_integer()" в файле lib/element.c. Удаленный пользователь может вызвать сбой работы приложения.

URL производителя: http://www.gnu.org/

Решение: Установите последнюю версию 3.6 с сайта производителя.

Ссылки: http://lists.gnu.org/archive/html/help-libtasn1/2014-05/msg00006.html

или введите имя

CAPTCHA