Обход ограничений безопасности в WordPress Query Interface Plugin

Дата публикации:
03.06.2014
Дата изменения:
03.06.2014
Всего просмотров:
491
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:P/I:P/A:P/E:U/RL:O/RC:C) = Base:7.5/Temporal:5.5
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress Query Interface Plugin 1.x
Уязвимые версии: WordPress Query Interface Plugin 1.x, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю обойти ограничения безопасности.

Уязвимость существует из-за того, что приложение не правильно ограничивает доступ к сценарию wp-content/plugins/query-interface/qi.php. Удаленный пользователь может получить доступ к ограниченной функциональности и затем с помощью специально сформированного запроса выполнить произвольные SQL команды и выполнить произвольный код SQL.

URL производителя: http://freecode.com/projects/wordpress-query-interface-sql-reporting

Решение: Установите последнюю версию 1.2 или выше с сайта производителя.

Ссылки: http://freecode.com/projects/wordpress-query-interface-sql-reporting/releases
https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=907243%40query-interface&old=899114%40query-interface

или введите имя

CAPTCHA