Множественные уязвимости в Dotclear

Дата публикации:
28.05.2014
Дата изменения:
28.05.2014
Всего просмотров:
382
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
3
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C) = Base:4.3/Temporal:3.2
(AV:N/AC:L/Au:N/C:P/I:P/A:P/E:U/RL:OF/RC:C) = Base:7.5/Temporal:5.5
(AV:N/AC:L/Au:N/C:P/I:P/A:P/E:U/RL:OF/RC:C) = Base:7.5/Temporal:5.5
CVE ID:
CVE-2014-3781
CVE-2014-3782
CVE-2014-3783
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
Обход ограничений безопасности
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Dotclear 2.x
Уязвимые версии: Dotclear 2.6.2, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю обойти ограничения безопасности, выполнить произвольный код на целевой системе и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за ошибки в функции "dcXmlRpc::setUser()" в файле inc/core/class.dc.xmlrpc.php при обработке аутентификации с интерфейсом XML-RPC. Удаленный пользователь может получить несанкционированный доступ к приложению.
Для успешной эксплуатации уязвимости требуется чтоб интерфейс XML-RPC был включен (по умолчанию отключено).

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "categories_order" в сценарии admin/categories.php (когда установлен в "categories_order"). Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.
Для успешной эксплуатации уязвимости требуется "manage categories" разрешение. 3. Приложение позволяет загружать файлы с определенными расширениями в папку внутри корневой директории. Удаленный пользователь может, например, загрузить вредоносный PHP скрипт и выполнить произвольный код PHP.

URL производителя: http://dotclear.org/

Решение: Установите последнюю версию 2.6.3 с сайта производителя.

Ссылки: http://dotclear.org/blog/post/2014/05/16/Dotclear-2.6.3
http://karmainsecurity.com/KIS-2014-05
http://karmainsecurity.com/KIS-2014-06
http://karmainsecurity.com/KIS-2014-07

или введите имя

CAPTCHA