Множественные уязвимости в CoSoSys Endpoint Protector

Дата публикации:
28.05.2014
Дата изменения:
28.05.2014
Всего просмотров:
474
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:A/AC:L/Au:N/C:P/I:N/A:N/E:U/RL:OF/RC:C) = Base:3.3/Temporal:2.4
(AV:A/AC:L/Au:N/C:P/I:P/A:P/E:U/RL:OF/RC:C) = Base:5.8/Temporal:4.3
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная сеть
Воздействие:
Раскрытие системных данных
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
CoSoSys Endpoint Protector 4.x
Уязвимые версии: CoSoSys Endpoint Protector 4.4.0.2, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю получить доступ к определенной конфиденциальной информации и выполнить произвольные SQL команды в базе данных приложения.

1. Приложение не правильно ограничить доступ к страницам /nginx_status и /munin. Удаленный пользователь может получить доступ системной информации и раскрыть статистику веб-сервера.

2. Уязвимость существует из-за недостаточной обработки входных данных в сценарии /wsf/webservice.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения и, например, создать произвольные файлы или добавить пользователя с учетной записью администратора.

URL производителя: http://www.cososys.com/

Решение: Установите последнюю версию 4.4.0.3 с сайта производителя.

Ссылки: https://www.sec-consult.com/fxdata/seccons/prod/temedia/advisories_txt/20140521-CoSoSys_Endpoint_Protector_Multiple_Vulnerabilities_v10_wo_poc.txt

или введите имя

CAPTCHA