Обход ограничений безопасности в mod_wsgi

Дата публикации:
27.05.2014
Дата изменения:
27.05.2014
Всего просмотров:
587
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
CVE-2014-0240
Вектор эксплуатации:
Удаленная
Воздействие:
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
mod_wsgi 3.x
Уязвимые версии: mod_wsgi 3.x, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю обойти ограничения безопасности.

Уязвимость существует из-за того, что приложение не правильно обрабатывает коды специфических ошибк Linux в "setuid()". Удаленный пользователь может получить доступ к иным ограниченны правам.
Для успешной эксплуатации уязвимости требуется чтоб mod_wsgi работал в режиме демона Linux системы, использующих версии ядра до 3.1.0.

URL производителя: https://code.google.com/p/modwsgi/

Решение: Установите последнюю версию 3.5 с сайта производителя.

Ссылки: https://code.google.com/p/modwsgi/wiki/ChangesInVersion0305

или введите имя

CAPTCHA