Множественные уязвимости в TYPO3

Дата публикации:
23.05.2014
Дата изменения:
23.05.2014
Всего просмотров:
528
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
5
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C) = Base:4.3/Temporal:3.2
(AV:N/AC:L/Au:N/C:P/I:P/A:P/E:U/RL:OF/RC:C) = Base:7.5/Temporal:5.5
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C) = Base:4.3/Temporal:3.2
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C) = Base:4.3/Temporal:3.2
(AV:N/AC:L/Au:N/C:P/I:N/A:N/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Раскрытие важных данных
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
TYPO3 4.x
TYPO3 6.x
Уязвимые версии: TYPO3 4.x, 6.х, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение, получить доступ к определенной конфиденциальной информации и обойти ограничения безопасности.

1. Уязвимость существует из-за недостаточной обработки входных данных в Host HTTP Header. Удаленный пользователь может подменить заголовок узла, и например отправить ссылку для сброса пароля.

2. Компонент Color Picker Wizard использует функцию "unserialize()" с контролем ввода пользователя. Подробности уязвимости не раскрываются.
Эта уязвимость существует в версиях 4.5.0 через 4.5.33, 4.7.0 через 4.7.18, 6.0.0 через 6.0.13 и 6.1.0 через 6.1.8.

3. Уязвимость существует из-за недостаточной обработки входных данных Backend. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

4. Уязвимость существует из-за недостаточной обработки входных данных в typo3/contrib/extjs/resources/charts.swf. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.
Уязвимости №1, №3 и №4 представлены в версиях 4.5.0 через 4.5.33, 4.7.0 через 4.7.18, 6.0.0 через 6.0.13, 6.1.0 через 6.1.8 и 6.20 через 6.2.2.

5. Уязвимость существует из-за ошибки в механизме кэширования Extbase. Удаленный пользователь может раскрыть группы других пользователей в кэше запросов.

URL производителя: http://typo3.org/

Решение: Установите последнюю версию 4.5.34, 4.7.19, 6.0.14, 6.1.9 или 6.2.3 с сайта производителя.

Ссылки: http://typo3.org/teams/security/security-bulletins/typo3-core/typo3-core-sa-2014-001/

или введите имя

CAPTCHA