Компрометация системы в CHICKEN

Дата публикации:
22.05.2014
Дата изменения:
22.05.2014
Всего просмотров:
480
Опасность:
Средняя
Наличие исправления:
Инстуркции по устранению
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:P/I:P/A:P/E:U/RL:W/RC:C) = Base:7.5/Temporal:6.1
CVE ID:
CVE-2014-3776
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
CHICKEN 4.x
Уязвимые версии: CHICKEN 4.8.0.6, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за ошибки в процедуре "read-u8vector!" в блоке "srfi-4" когда "#f" передается как аргумент "NUM". Удаленный пользователь может вызвать переполнение буфера.
Для успешной эксплуатации уязвимости пользователь может выполнить произвольный код на целевой системе.

URL производителя: http://www.call-cc.org/

Решение: Исправлено в репозитории.

Ссылки: http://lists.gnu.org/archive/html/chicken-announce/2014-05/msg00001.html

или введите имя

CAPTCHA