Манипуляция данными в eGroupWare

Дата публикации:
22.05.2014
Дата изменения:
22.05.2014
Всего просмотров:
488
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:5/Temporal:3.7
CVE ID:
CVE-2014-2027
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
eGroupWare 1.x
Уязвимые версии: eGroupWare 1.x, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю манипулировать определенными важными данными.

Уязвимость существует из-за недостаточной обработки входных данных в различных параметрах и сценариях в функции "unserialize()". Удаленный пользователь может манипулировать определенными файлами создать или перезаписать.
Список уязвимых параметров:
http://[host]/addressbook/csv_import.php?action=next&addr_fields&trans (POST)
http://[host]/calendar/csv_import.php?action=next&cal_fields&trans (POST)
http://[host]/index.php?menuaction=preferences.uiaclprefs.index&processed (POST)

Примечание: Также пользователь может с помощью специально сформированного сериализованного объекта выполнить произвольный код PHP на целевой системе.

Для успешной эксплуатации уязвимости требуется знать полный путь к файлу, который пропишется в приложении и будет запущен на ОС UNIX/Linux..

URL производителя: http://www.egroupware.org/

Решение: Установите последнюю версию 1.8.006.20140217 с сайта производителя.

Ссылки: http://www.egroupware.org/changelog
https://github.com/pedrib/PoC/blob/master/egroupware-1.8.005.txt

или введите имя

CAPTCHA