Компрометация системы в D-Link DSP-W215

Дата публикации:
21.05.2014
Дата изменения:
21.05.2014
Всего просмотров:
599
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:A/AC:L/Au:N/C:C/I:C/A:C/E:U/RL:O/RC:C) = Base:8.3/Temporal:6.1
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная сеть
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
D-Link DSP-W215
Уязвимые версии: D-Link DSP-W215 1.01b06, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код устройстве.

Уязвимость существует из-за ошибки проверки границ данных в функции "do_hnap()" в файле /www/my_cgi.cgi при обработке заголовков "Content-Length". Удаленный пользователь может с помощью специально сформированных запросов SOAP "GetDeviceSettings" HNAP вызвать переполнение стека буфера.

URL производителя: http://www.dlink.com/

Решение: Установите последнюю версию 1.02b05 с сайта производителя

Ссылки: http://securityadvisories.dlink.com/security/publication.aspx?name=SAP10027
http://www.devttys0.com/2014/05/hacking-the-d-link-dsp-w215-smart-plug/

или введите имя

CAPTCHA