Множественные уязвимости в Moodle

Дата публикации:
20.05.2014
Дата изменения:
20.05.2014
Всего просмотров:
607
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
5
CVSSv2 рейтинг:
(AV:N/AC:H/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C) = Base:2.6/Temporal:1.9
(AV:N/AC:L/Au:N/C:P/I:N/A:N/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
(AV:N/AC:L/Au:N/C:P/I:N/A:N/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
(AV:N/AC:L/Au:N/C:P/I:N/A:N/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
CVE-2014-0213
CVE-2014-0215
CVE-2014-0216
CVE-2014-0217
CVE-2014-0218
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Раскрытие важных данных
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Moodle 2.4.x
Moodle 2.5.x
Moodle 2.6.x
Уязвимые версии: Moodle 2.4.x, 2.5.x, 2.6.x, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю обойти ограничения безопасности, произвести XSS нападение и получить доступ к определенной конфиденциальной информации.

1. Уязвимость существует из-за недостаточной проверки подлинности HTTP запросов. Удаленный пользователь может с помощью специально сформированной ссылки осуществить CSRF нападение.

2. Уязвимость существует из-за ошибки в присвоении веб-страниц. Удаленный пользователь может получить доступ к некоторой информации анонимного пользователя в источнике страницы.

3. Уязвимость существует из-за ошибки в разделе My Home Page при обработке файлов с блоков HTML. Удаленный пользователь может получить доступ к иным ограниченным файлам.

4. Уязвимость существует из-за ошибки в зачисленных станицах. Удаленный пользователь может получить доступ к деталям скрытых курсов.
Эта уязвимость существует в версии 2.6 через 2.6.2

5. Уязвимость существует из-за недостаточной обработки входных данных в хранилище URL загрузчика. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.
Уязвимости №1-№3, №5 представлены в версии 2,6 через 2.6.2, 2.5 через 2.5.5 и 2.4 через 2.4.9.

URL производителя: http://moodle.com/hq/

Решение: Установите последнюю версию 2.7, 2.6.3, 2.5.6 или 2.4.10 с сайта производителя.

Ссылки: https://moodle.org/mod/forum/discuss.php?d=260361
https://moodle.org/mod/forum/discuss.php?d=260363
https://moodle.org/mod/forum/discuss.php?d=260364
https://moodle.org/mod/forum/discuss.php?d=260365
https://moodle.org/mod/forum/discuss.php?d=260366

или введите имя

CAPTCHA