Множественные уязвимости в Django

Дата публикации:
16.05.2014
Дата изменения:
16.05.2014
Всего просмотров:
859
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:P/I:N/A:N/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
CVE-2014-1418
CVE-2014-3730
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Спуфинг атака
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Django 1.4.x
Django 1.5.x
Django 1.6.x
Уязвимые версии:
Django 1.4.x
Django 1.5.x
Django 1.6.x, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю совершить спуфинг атаку и получить доступ к определенной конфиденциальной информации.

1. Уязвимость существует из-за ошибки в заголовках куки "Vary" при обработке разных типов контента. Удаленный пользователь может получить доступ к контенту других сессий.

2. Уязвимость существует из-за недостаточной обработки входных данных. Удаленный пользователь может с помощью специально сформированной ссылки, размещенной на доверенном домене, перенаправить пользователя на произвольный сайт.

URL производителя: https://www.djangoproject.com/foundation/

Решение: Установите последнюю версию 1.6.5, 1.5.8 и 1.4.13 с сайта производителя.

Ссылки: https://www.djangoproject.com/weblog/2014/may/14/security-releases-issued/

или введите имя

CAPTCHA