Множественные уязвимости в WordPress TinyMCE Color Picker Plugin

Дата публикации:
13.05.2014
Дата изменения:
13.05.2014
Всего просмотров:
884
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:H/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C) = Base:2.6/Temporal:1.9
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress TinyMCE Color Picker Plugin 1.x
Уязвимые версии: WordPress TinyMCE Color Picker Plugin 1.x, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и обойти ограничения безопасности.

1. Уязвимость существует из-за недостаточной проверки подлинности HTTP запросов в приложении. Удаленный пользователь может с помощью специально сформированной ссылки осуществить CSRF нападение и манипулировать настройками модуля.

2. Приложение не правильно проверяет полномочия при обновлении настроек модуля. Удаленный пользователь может с помощью специально сформированного запроса получить доступ к иным ограниченным настройкам.

URL производителя: http://wordpress.org/plugins/tinymce-colorpicker/

Решение: Установите последнюю версию 1.2 с сайта производителя.

Ссылки: http://wordpress.org/plugins/tinymce-colorpicker/changelog/

или введите имя

CAPTCHA