Отказ в обслуживании в Netty

Дата публикации:
07.05.2014
Дата изменения:
07.05.2014
Всего просмотров:
458
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:N/A:P/E:U/RL:O/RC:C) = Base:5/Temporal:3.7
CVE ID:
CVE-2014-0193
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Netty 3.x
Netty 4.x
Уязвимые версии: Netty 3.х, 4.х, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании приложения.

Уязвимость существует из-за ошибки в классе WebSocket08FrameDecoder. Удаленный пользователь может исчерпать все доступные ресурсы памяти и аварийно завершить работу приложения.

URL производителя: http://netty.io/index.html

Решение: Установите последнюю версию 4.0.19.Final, 3.9.1.Final, 3.8.2.Final, 3.7.1.Final или 3.6.9.Final с сайта производителя.

Ссылки: http://netty.io/news/2014/04/30/release-day.html

или введите имя

CAPTCHA