Межсайтовый скриптинг в WordPress NextCellent Gallery Plugin

Дата публикации:
07.05.2014
Дата изменения:
07.05.2014
Всего просмотров:
924
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
CVE-2014-3123
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress NextCellent Gallery Plugin 1.x
Уязвимые версии: WordPress NextCellent Gallery Plugin 1.x, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в поле "Alt & Title". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта, при просмотре вредоносных данных.

Для успешной эксплуатации уязвимости требуется разрешение на "NextGEN Upload images", "NextGEN Manage gallery" или "NextGEN Manage others gallery".

URL производителя: http://wpgetready.com/nextcellent-gallery/

Решение: Установите последнюю версию 1.9.18 с сайта производителя.

Ссылки: https://wordpress.org/plugins/nextcellent-gallery-nextgen-legacy/changelog/
http://www.vapid.dhs.org/advisories/wordpress/plugins/nextCellent-gallery-1.9.13/

или введите имя

CAPTCHA