Обход ограничений безопасности в Apache Struts

Дата публикации:
07.05.2014
Дата изменения:
07.05.2014
Всего просмотров:
639
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:C/A:N/E:U/RL:OF/RC:C) = Base:7.1/Temporal:5.3
CVE ID:
CVE-2014-0116
Вектор эксплуатации:
Удаленная
Воздействие:
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Apache Struts 2.x
Уязвимые версии: Apache Struts 2.x, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю обойти ограничения безопасности.

Уязвимость существует из-за того, что приложение не должным образом ограничивает доступ к параметру "class", который непосредственно относится к методу "getClass()" через CookieInterceptor. Удаленный пользователь сможет манипулировать ClassLoader, используемый сервером приложений и в последствии изменить состояние сеанса или запроса.
Эта уязвимость существует из-за неполного временного решения проблемы CVE-2014-0113.
Подробное описание доступно по адресу:
http://www.securitylab.ru/vulnerability/452309.php№2

URL производителя: http://apache.org/

Решение: Установите последнюю версию 2.3.16.3 с сайта производителя.

Ссылки: http://struts.apache.org/release/2.3.x/docs/s2-022.html

или введите имя

CAPTCHA