Обход ограничений безопасности в strongSwan

Дата публикации:
16.04.2014
Дата изменения:
16.04.2014
Всего просмотров:
626
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:C/A:N/E:U/RL:O/RC:C) = Base:7.1/Temporal:5.3
CVE ID:
CVE-2014-2338
Вектор эксплуатации:
Удаленная
Воздействие:
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
strongSwan 4.x
strongSwan 5.x
Уязвимые версии: strongSwan 4.х, 5.x,возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю обойти ограничения безопасности.

Уязвимость существует из-за ошибки при передаче манипуляций с ключами из неустановленного IKEv2 SA в период инициализации активации. Удаленный пользователь может обойти механизм аутентификации и получить ограниченный доступ.

URL производителя: http://strongswan.org/

Решение: Установите последнюю версию с сайта производителя.

Ссылки: http://strongswan.org/blog/2014/04/14/strongswan-authentication-bypass-vulnerability-(cve-2014-2338).html

или введите имя

CAPTCHA