Повышение привилегий в Xen

Дата публикации:
07.04.2014
Дата изменения:
07.04.2014
Всего просмотров:
572
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:L/AC:L/Au:N/C:C/I:C/A:C/E:U/RL:O/RC:C) = Base:7.2/Temporal:5.3
CVE ID:
CVE-2014-1642
Вектор эксплуатации:
Локальная
Воздействие:
Отказ в обслуживании
Повышение привилегий
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Xen 4.x
Уязвимые версии: Xen 4.2.x и 4.3.x, возможно более ранние версии

Описание:
Уязвимость позволяет локальному пользователю повысить свои привилегии на системе или вызвать отказ в обслуживании.

Уязвимость существует из-за ошибки двойного освобождения в функции "pirq_guest_bind()" в файле xen/arch/x86/irq.c при обработке ошибок во время установки IRQ. Локальный пользователь может вызвать повреждение памяти.

URL производителя: http://www.xenproject.org/developers/teams/hypervisor.html

Решение: Установите исправление xsa83.patch с сайта производителя.

Ссылки: http://lists.xen.org/archives/html/xen-announce/2014-01/msg00000.html
http://lists.xen.org/archives/html/xen-announce/2014-01/msg00001.html

или введите имя

CAPTCHA