Межсайтовый скриптинг в Drupal Print Module (Printer, e-mail and PDF versions)

Дата публикации:
04.04.2014
Дата изменения:
04.04.2014
Всего просмотров:
764
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Drupal Print Module 7.x
Drupal Print Module 6.x
Уязвимые версии:
Drupal Print Module 6.x (Printer, e-mail and PDF versions)
Drupal Print Module 7.x (Printer, e-mail and PDF versions), возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в узлах. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта, при котором вредоносные данные просматриваются.

Для успешной эксплуатации уязвимости требуется разрешение на создание узла, который предлагает функцию печати.

URL производителя: https://drupal.org/project/print

Решение: Установите последнюю версию 6.x-1.19, 7.x-1.3 или 7.x-2.0 с сайта производителя.

Ссылки: https://drupal.org/node/2231671

или введите имя

CAPTCHA