Компрометация системы в psych gem for Ruby

Дата публикации:
31.03.2014
Дата изменения:
31.03.2014
Всего просмотров:
629
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:P/I:C/A:P/E:U/RL:O/RC:C) = Base:9/Temporal:6.7
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
psych gem for Ruby 2.x
Уязвимые версии: psych gem for Ruby 2.x, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный код на целевой системе.

Уязвимость существует из-за прилагаемой в комплекте уязвимой версии libyaml.
Подробное описание уязвимости доступно по адресу:
http://www.securitylab.ru/vulnerability/450942.php

URL производителя: https://rubygems.org/gems/psych

Решение: Установите последнюю версию 2.0.5 с сайта производителя

Ссылки: https://www.ruby-lang.org/en/news/2014/03/29/heap-overflow-in-yaml-uri-escape-parsing-cve-2014-2525/

или введите имя

CAPTCHA