Манипуляция данными в Phusion Passenger gem for Ruby

Дата публикации:
27.03.2014
Дата изменения:
27.03.2014
Всего просмотров:
957
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:L/AC:L/Au:N/C:P/I:N/A:N/E:U/RL:O/RC:C) = Base:2.1/Temporal:1.6
CVE ID:
CVE-2014-1832
Вектор эксплуатации:
Локальная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Phusion Passenger gem for Ruby 4.x
Уязвимые версии: Phusion Passenger gem for Ruby 4.x, возможно более ранние версии

Описание:
Уязвимость позволяет локальному пользователю манипулировать важными данными.

Уязвимость существует из-за ошибки состояния операции при создании определенного временного каталога. Удаленный пользователь может с помощью символических ссылок атак манипулировать содержанием определенных файлов.

Примечание: Уязвимость существует из-за ненадлежащего временного решения проблемы CVE-2014-1831.

URL производителя: http://phusion.nl

Решение: Установите последнюю версию 4.0.38 с сайта производителя.

Ссылки: https://github.com/phusion/passenger/commit/94428057c602da3d6d34ef75c78091066ecac5c0
http://www.openwall.com/lists/oss-security/2014/01/29/6

или введите имя

CAPTCHA