Манипуляция данными в ImpressCMS

Дата публикации:
26.03.2014
Дата изменения:
26.03.2014
Всего просмотров:
455
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:C/A:N/E:U/RL:U/RC:C) = Base:7.1/Temporal:6
CVE ID:
CVE-2014-1836
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
ImpressCMS 1.x
Уязвимые версии: ImpressCMS 1.3.5, 1.3.6 и 1.3.6.1, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю манипулировать определенными важными данными.

Уязвимость существует из-за недостаточной обработки входных данных в параметре HTTP GET "image_path" в сценарии libraries/image-editor/image-edit.php (когда "op" установлен в положении "cancel") при удалении файлов. Удаленный пользователь может в обход последовательности каталогов удалить произвольные файлы.

URL производителя: http://www.impresscms.org

Решение: Установите исправление 1.3.6 (исправление эффективно частично) с сайта производителя. Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://community.impresscms.org/modules/smartsection/item.php?itemid=675
https://github.com/pedrib/PoC/blob/master/impresscms-1.3.5.txt

или введите имя

CAPTCHA