Множественные уязвимости в e107

Дата публикации:
11.03.2014
Дата изменения:
11.03.2014
Всего просмотров:
708
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:ND/RC:C) = Base:4.3/Temporal:0
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:ND/RC:C) = Base:4.3/Temporal:0
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
e107 1.x
Уязвимые версии: e107 1.0.4, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре HTTP POST "comment" в сценарии news.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.
Для успешной эксплуатации уязвимости требуется чтобы опция в пункте новость "Allow comments to be posted to this news item" была включена.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре HTTP POST "multilanguage_subdomain" в сценарии /e107_admin/language.php и в параметре HTTP POST "meta_author" в сценарии /e107_admin/meta.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: http://e107.org

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: https://www.netsparker.com/critical-xss-and-sql-injection-vulnerabilities-in-e107/<

или введите имя

CAPTCHA