Множественные уязвимости в Embedthis GoAhead

Дата публикации:
06.03.2014
Дата изменения:
06.03.2014
Всего просмотров:
595
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:N/A:P/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Embedthis GoAhead 3.x
Уязвимые версии: Embedthis GoAhead 3.x, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю вызвать отказ в обслуживании приложения.

1. Уязвимость существует из-за ошибки при синтаксическом анализе URL в функции "websUrlParse()" в файле src/http.c, Удаленный пользователь может с помощью специально сформированного URL запроса аварийно завершить работу приложения.

2. Уязвимость существует из-за иной ошибки при синтаксическом анализе URL в функции "websUrlParse()" в файле src/http.c, Удаленный пользователь может с помощью специально сформированного URL запроса аварийно завершить работу приложения.

3. Уязвимость существует из-за ошибки при синтаксическом анализе URL в функции "websUrlParse()" в файле src/http.c, Удаленный пользователь может с помощью специально сформированного URL запроса аварийно завершить работу приложения.

URL производителя: http://embedthis.com

Решение: Установите последнюю версию 3.3.0 с сайта производителя.

Ссылки: http://embedthis.com/products/goahead/doc/product/changeLog.html
https://github.com/embedthis/goahead/issues/81
http://packetstormsecurity.com/files/125349/Embedthis-Goahead-3.1.3-0-Denial-Of-Service.html

или введите имя

CAPTCHA