Межсайтовый скриптинг в Welcart e-Commerce plugin for WordPress

Дата публикации:
04.03.2014
Дата изменения:
04.03.2014
Всего просмотров:
1023
Опасность:
Низкая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:U/RC:C) = Base:4.3/Temporal:3.7
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress Welcart e-Commerce Plugin 1.x
Уязвимые версии: WordPress Welcart e-Commerce Plugin 1.3.12, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметрах HTTP POST "name", "intl", "nocod" и "time" в сценарии wp-admin/admin-ajax.php (когда "action" установлен в "shop_options_ajax" и "mode" установлен в "add_delivery_method"). Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: http://www.welcart.com

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://packetstormsecurity.com/files/125513/Welcart-e-Commerce-usc-e-shop.1.3.12-XSS-SQL-Injection.html

или введите имя

CAPTCHA