Множественные уязвимости в InterWorx

Дата публикации:
28.02.2014
Дата изменения:
28.02.2014
Всего просмотров:
1048
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C) = Base:4.3/Temporal:3.2
(AV:N/AC:M/Au:N/C:P/I:P/A:N/E:U/RL:OF/RC:C) = Base:5.8/Temporal:4.3
CVE ID:
CVE-2014-2035
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Раскрытие важных данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
InterWorx 5.x
Уязвимые версии: InterWorx 5.0.12 build 569, возможно более ранние версии

Описание:
Уязвимости позволяют удаленному пользователю получить доступ к важным данным и произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "i" в сценарии xhr.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных при выполнении команд в интерфейсе SiteWorx. Удаленный пользователь может получить доступ к базе данных MySQL и раскрыть учетные данные "iworx" пользователей.

URL производителя: http://www.interworx.com/company

Решение: Установите последнюю версию 5.0.13 build 574 с сайта производителя.

Ссылки: http://www.interworx.com/developers/changelog/version-5-0-13-build-574-2014-02-19/
http://archives.neohapsis.com/archives/bugtraq/2014-02/0107.html
https://blog.rack911.com/security-advisories/interworx-siteworx-mysql-password-disclosure-vulnerability-r911-0129/

или введите имя

CAPTCHA