Множественные уязвимости в BuddyPress plugin for WordPress

Дата публикации:
27.02.2014
Дата изменения:
27.02.2014
Всего просмотров:
2348
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C) = Base:4.3/Temporal:3.2
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C) = Base:4.3/Temporal:3.2
CVE ID:
CVE-2014-1888
CVE-2014-1889
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WordPress BuddyPress Plugin 1.x
Уязвимые версии: WordPress BuddyPress Plugin 1.9.1, возможно другие версии.

Описание:
Уязвимости позволяют удаленному пользователю обойти ограничения безопасности и произвести XSS нападение.

1. Уязвимость существует из-за ошибки при работе с cookie в параметре "bp_new_group_id". Удаленный пользователь может получить доступ к запрещенной группе пользователей.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре поля формы "group-name" при создании новой группы. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: http://buddypress.org

Решение: Установите последнюю версию 1.9.2 с сайта производителя.

Ссылки: http://buddypress.org/2014/02/buddypress-1-9-2/
http://packetstormsecurity.com/files/125212/WordPress-Buddypress-1.9.1-Cross-Site-Scripting.html
http://packetstormsecurity.com/files/125213/WordPress-Buddypress-1.9.1-Privilege-Escalation.html

или введите имя

CAPTCHA