Повышение привилегий в Linux ptrace

Дата публикации:
18.02.2013
Всего просмотров:
309
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:L/AC:M/Au:N/C:C/I:C/A:C/E:U/RL:O/RC:C) = Base:6.9/Temporal:5.1
CVE ID:
CVE-2013-0871
Вектор эксплуатации:
Локальная
Воздействие:
Повышение привилегий
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Linux Kernel 3.4.x
Linux Kernel 2.6.x
Уязвимые версии: Linux kernel версии до 2.6.32.61 и 3.4.28.

Описание:
Уязвимость позволяет локальному пользователю повысить свои привилегии на системе.

Уязвимость существует из-за ошибки состояния операции при обработке определенных ptrace действий. Локальный пользователь может прочитать и записать данные в произвольную ячейку памяти в стеке и выполнить произвольный код на целевой системе с привилегиями суперпользователя.

URL производителя: www.kernel.org

Решение: Установите последнюю версию 2.6.32.61 или 3.4.28 с сайта производителя.

Ссылки: https://www.kernel.org/pub/linux/kernel/v2.6/longterm/v2.6.32/ChangeLog-2.6.32.61
http://www.kernel.org/pub/linux/kernel/v3.0/ChangeLog-3.4.28
http://www.openwall.com/lists/oss-security/2013/02/15/16

или введите имя

CAPTCHA