Множественные уязвимости в Open Web Analytics

Дата публикации:
17.02.2014
Дата изменения:
17.02.2014
Всего просмотров:
840
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:M/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C) = Base:4.3/Temporal:3.2
(AV:N/AC:H/Au:N/C:P/I:P/A:P/E:U/RL:OF/RC:C) = Base:5.1/Temporal:3.8
CVE ID:
CVE-2014-1456
CVE-2014-1457
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Open Web Analytics 1.x
Уязвимые версии: Open Web Analytics 1.5.4 и 1.5.5, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "owa_user_id" на странице ввода пароля. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной проверки подлинности HTTP запросов. Удаленный пользователь может с помощью специально сформированной ссылки осуществить CSRF нападение и удалить приложения и получить доступ к определенным данным или выполнять определенные действия связанные с управлением приложений.

URL производителя: http://www.openwebanalytics.com

Решение: Установите последнюю версию 1.5.6 с сайта производителя.

Ссылки: http://www.openwebanalytics.com/?p=384
http://www.secureworks.com/advisories/SWRX-2014-004/SWRX-2014-004.pdf
http://www.secureworks.com/advisories/SWRX-2014-006/SWRX-2014-006.pdf

или введите имя

CAPTCHA