Множественные уязвимости в Web Video Streamer

Дата публикации:
04.02.2014
Дата изменения:
04.02.2014
Всего просмотров:
729
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
(AV:N/AC:L/Au:N/C:N/I:P/A:P/E:U/RL:OF/RC:C) = Base:6.4/Temporal:4.7
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Web Video Streamer 1.x
Уязвимые версии: Web Video Streamer 1.0, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре HTTP GET "dir" в index.php и в параметре HTTP GET "name" в player.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре HTTP GET "file" в player.php не проверяются должным образом перед использованием в "exec()". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта и выполнить произвольные команды.

URL производителя: https://github.com/OliverLeitner/webstreamer

Решение: Установите последнюю версию 1.1 с сайта производителя.

Ссылки: https://github.com/OliverLeitner/webstreamer/blob/master/changelog.txt
http://www.rusty-ice.de/advisory/advisory_2014003.txt

или введите имя

CAPTCHA