Множественные уязвимости в Moodle

Дата публикации:
21.01.2014
Дата изменения:
21.01.2014
Всего просмотров:
1610
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:A/AC:H/Au:N/C:P/I:P/A:N/E:U/RL:OF/RC:C) = Base:3.2/Temporal:2.4
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
CVE ID:
CVE-2014-0009
CVE-2014-0010
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Moodle 2.3.x
Moodle 2.4.x
Moodle 2.5.x
Moodle 2.6.x
Уязвимые версии: Moodle 2.3.10, 2.4.7, 2.5.4, 2.6, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести CSRF нападение.

1. Уязвимость существует из-за ошибки в "login-as" функция может быть использована для входа пользователя, принадлежащего к другой группе.

2. Уязвимость существует из-за недостаточной проверки подлинности HTTP запросов. Удаленный пользователь может с помощью специально сформированной ссылки осуществить CSRF нападение и удалить поля профилей и категории пользователей.

URL производителя: http://moodle.com/hq/

Решение: Установите последнюю версию 2.3.11, 2.4.8, 2.5.4 и 2.6.1 с сайта производителя.

Ссылки: https://moodle.org/mod/forum/discuss.php?d=252415
https://moodle.org/mod/forum/discuss.php?d=252416

или введите имя

CAPTCHA