Множественные уязвимости в Pet Listing Script

Дата публикации:
20.01.2014
Дата изменения:
20.01.2014
Всего просмотров:
539
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
2
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:N/I:P/A:N/E:U/RL:OF/RC:C) = Base:5/Temporal:3.7
(AV:N/AC:H/Au:N/C:P/I:P/A:P/E:U/RL:OF/RC:C) = Base:5.1/Temporal:3.8
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Pet Listing Script 1.x
Уязвимые версии: Pet Listing Script 1.х, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в различных HTTP POST параметрах в сценарии /index.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

Список уязвимых параметров:
http://[host]/index.php?controller=AdminTypes&action=create&type_title
http://[host]/index.php?index.php?controller=AdminBreeds&action=create&breed_title
http://[host]/index.php?controller=AdminExtras&action=create&extra_title

2. Уязвимость существует из-за недостаточной проверки подлинности HTTP запросов. Удаленный пользователь может с помощью специально сформированной ссылки осуществить CSRF нападение и создать учетную запись администратора.

URL производителя: http://stivasoft.com/ <

Решение: Установите последнюю версию с сайта производителя.

Ссылки: http://www.exploit-db.com/exploits/30950/

или введите имя

CAPTCHA