Межсайтовый скриптинг в omniauth-facebook gem for Ruby

Дата публикации:
20.11.2013
Дата изменения:
20.11.2013
Всего просмотров:
1030
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:H/Au:N/C:N/I:P/A:N/E:U/RL:O/RC:C) = Base:2.6/Temporal:1.9
CVE ID:
CVE-2013-4562
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
omniauth-facebook gem for Ruby 1.x
Уязвимые версии: omniauth-facebook gem for Ruby версий до 1.5.0

Описание:
Уязвимость позволяет удаленному пользователю осуществить XSS-атаку.

Уязвимость существует из-за недостаточной проверки подлинности HTTP запросов при выполнении некоторых действий. Удаленный пользователь может произвести CSRF нападение.

URL производителя: https://github.com/mkdynamic/omniauth-facebook

Решение: Для устранения уязвимости установите продукт версии 1.5.0 с сайта производителя.

Ссылки: http://www.openwall.com/lists/oss-security/2013/11/12/5

или введите имя

CAPTCHA