Обход ограничения безопасности в cocaine gem for Ruby

Дата публикации:
29.10.2013
Дата изменения:
29.10.2013
Всего просмотров:
1039
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
(AV:N/AC:L/Au:N/C:P/I:P/A:P/E:U/RL:O/RC:C) = Base:7.5/Temporal:5.5
CVE ID:
CVE-2013-4457
Вектор эксплуатации:
Удаленная
Воздействие:
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
cocaine gem for Ruby 0.x
Уязвимые версии: WordPress Bank Gallery Plugin версий до 0.5.3 Описание:
Уязвимость позволяет удаленному пользователю обойти ограничения безопасности на целевой системе.

Уязвимость существует из-за ошибки при обработке хеш-объектов. Удаленный пользователь может обойти независимый параметр и выполнить произвольную команду операционной системы.

URL производителя: http://rubygems.org/gems/cocaine

Решение: Для устранения уязвимости установите продукт версии 0.5.3 из сайта производителя.

Ссылки: http://www.openwall.com/lists/oss-security/2013/10/22/10

или введите имя

CAPTCHA